Login errors
Incident Report for MyFreeCams
Resolved
This incident has been resolved.
Posted Aug 10, 2021 - 16:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2021 - 16:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 10, 2021 - 16:01 UTC
Investigating
We are investigating issues preventing users from logging into MyFreeCams. We're working to restore service as soon as possible.
Posted Aug 10, 2021 - 15:52 UTC
This incident affected: Website, Chat, Video, Billing, MFC Share, Features, and CharlesBot.