Slow page loading while accessing MFC Share
Incident Report for MyFreeCams
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 15:58 UTC
Investigating
We're investigating reports of slow page loading and error messages while accessing MFC Share.
Posted Jul 02, 2020 - 15:32 UTC
This incident affected: MFC Share.