Problems accessing MyFreeCams
Incident Report for MyFreeCams
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 10:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 01, 2024 - 09:54 UTC
Investigating
We are currently investigating problems while logging in to MyFreeCams
Posted Mar 01, 2024 - 09:29 UTC
This incident affected: Website, Chat, Video, Billing, MFC Share, Features, and CharlesBot.