Server maintenance
Incident Report for MyFreeCams
Resolved
Upgrades have been completed.
Posted May 14, 2019 - 16:49 UTC
Identified
We are performing important upgrades and maintenance at this time. We estimate these upgrades will take approximately 90 minutes.
Posted May 14, 2019 - 15:03 UTC
This incident affected: Website, Chat, Video, Billing, and CharlesBot.