Errors while accessing MyFreeCams
Incident Report for MyFreeCams
Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 21:16 UTC
Investigating
We are currently investigating problems with MyFreeCams. Updates will follow.
Posted Feb 15, 2021 - 21:02 UTC
This incident affected: Website, Chat, Video, Billing, MFC Share, Features, and CharlesBot.