Brief maintenance
Incident Report for MyFreeCams
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 01:39 UTC
Identified
MyFreeCams is performing brief maintenance. We will be back up as soon as possible.
Posted Oct 26, 2021 - 22:32 UTC
This incident affected: Website, Chat, Video, Billing, MFC Share, Features, and CharlesBot.