Connection problems
Incident Report for MyFreeCams
Resolved
All services should be fully restored. Thank you for your patience!
Posted Mar 18, 2018 - 23:20 UTC
Investigating
We're investigating problems with connecting to the site.
Posted Mar 18, 2018 - 22:45 UTC