MFC Share maintenance
Incident Report for MyFreeCams
Resolved
This maintenance has been completed. Thanks for your patience!
Posted Sep 09, 2021 - 16:09 UTC
Identified
We are performing important upgrades and maintenance on the MFC Share servers.

We apologize for any inconvenience. Thank you for your patience and support!
Posted Sep 09, 2021 - 15:28 UTC
This incident affected: MFC Share.